Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Sep 25, 2019 - 08:13 SAST
Identified
Withdrawals in South Africa will not be processed on 24 September 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 25 September 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted Sep 23, 2019 - 15:13 SAST