Delayed bank deposits and withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as scheduled
Posted Aug 03, 2020 - 06:48 UTC
Identified
There may be temporary delays in reflection of Malaysian deposits on 31st July.

Withdrawals in Malaysia will not be processed on 31st July due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 3rd August.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 29, 2020 - 06:19 UTC