Verification delays in Nigeria
Incident Report for Luno
Resolved
Verification times have returned to normal.
Posted Aug 21, 2018 - 05:55 UTC
Identified
Please note that we are currently unable to automatically verify our customers in Nigeria to Level 1 due to a technical issue with our verification partner, Seamfix. As a result, there may be some delays while waiting for your account to be verified. Kindly bear with us as we work to find a solution to this issue.
Posted Aug 15, 2018 - 14:26 UTC