Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Oct 28, 2019 - 13:35 SAST
Identified
There will be a slight delay with Nigerian bank withdrawals requested on 28 October 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted Oct 28, 2019 - 10:44 SAST