Delayed verification of beneficiaries NG
Incident Report for Luno
Resolved
The issue causing delays for Nigerian customers adding beneficiaries has been resolved.

We appreciate your patience.
Posted Nov 19, 2021 - 10:29 UTC
Investigating
We are currently investigating an issue that may cause delays for Nigerian customers adding beneficiaries.
Posted Nov 16, 2021 - 13:11 UTC