Android users may not see certain promotional content

Incident Report for Luno

Resolved

Update:

We are no longer seeing any issues for customers who use Android devices being unable to view certain marketing/promotional content in the Luno app.

We appreciate your patience in this matter.
Posted Oct 09, 2025 - 11:02 UTC

Identified

Customers who are using Android devices may not be able to see certain Marketing/Promotional content in the Luno app.

Customers who use Web or iOS will not be affected.

Our team has identified the issue and is working on it as a priority.

We apologise for any inconvenience caused.
Posted Oct 09, 2025 - 10:27 UTC