Delayed bank deposits and withdrawal in Zambia
Incident Report for Luno
Resolved
Deposits and withdrawals are being processed to according to our schedule.

Thank you!
Posted Jul 08, 2020 - 06:40 UTC
Identified
Deposits and withdrawals in Zambia will not be processed on 6th and 7th July due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Deposits and withdrawals will be processed on following business day, 8th July.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 06, 2020 - 06:34 UTC