Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
All withdrawals are being processed as normal. Thanks for your patience.
Posted Mar 11, 2024 - 11:39 UTC
Identified
Some withdrawals may still be delayed, we're working closely with the bank to see this resolved as soon as possible.
Posted Mar 11, 2024 - 10:26 UTC
Investigating
We're investigating the cause for slow bank withdrawals in South Africa, updates to follow.
Posted Mar 11, 2024 - 08:35 UTC