Delayed Crypto Sends

Incident Report for Luno

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 19:03 UTC

Identified

We have identified an issue that may be causing delayed crypto sends for some customers. Any crypto that is ETH network will be affected. Our team is working on resolving the issue. We apologise for the inconvenienced caused.
Posted Sep 01, 2025 - 16:53 UTC