PayU Maintenance in Nigeria
Incident Report for Luno
Resolved
The scheduled maintenance has been completed.
Posted Oct 09, 2020 - 04:50 UTC
Identified
One of our payments providers PayU will be performing some platform maintenance starting at 22:30 on 8 October 2020.

This may affect deposits through PayU on our app. Please use an alternative depositing method until the maintenance is complete.
Posted Oct 08, 2020 - 15:05 UTC