Delayed bank withdrawals in Zambia
Incident Report for Luno
Resolved
Withdrawals in Zambia are being processed according to schedule.

Thank you for your understanding.
Posted Sep 22, 2020 - 10:39 UTC
Monitoring
We updated the last status page update in error, apologies.
Some customers are still seeing slower than normal bank withdrawals in Zambia, our team are working on this as a priority.
Posted Sep 10, 2020 - 07:53 UTC