Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed as scheduled.
Posted Aug 03, 2020 - 06:48 UTC
Identified
Withdrawals in Indonesia will not be processed on 31st July due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 3rd of August.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jul 29, 2020 - 06:21 UTC