Bank withdrawals over the Festive Season 2019
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Jan 02, 2020 - 09:55 UTC
Identified
Banks do not process withdrawals over public holidays, so requested withdrawals during the festive season may be delayed. Please take note of the dates below when withdrawals will not be processed:

24 December 2019 - Indonesia
25 & 26 December 2019 - All regions
1 January 2020 - All regions

Withdrawals requested on these dates will be processed on the next business day.
Read the full withdrawal schedule here: https://www.luno.com/help/en/articles/11000022934

Please reach out to our team should you have any further questions https://www.luno.com/help/tickets/new

Bitcoin and Ethereum sends and receives will not be affected.
Posted Dec 17, 2019 - 07:35 UTC