Delayed bank withdrawal in Uganda
Incident Report for Luno
Resolved
Withdrawals are being processed according to schedule.

Thank you.
Posted Oct 12, 2020 - 07:04 UTC
Identified
Withdrawals in Uganda will not be processed on 9th of October due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 12th October.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Oct 09, 2020 - 07:00 UTC