Slow bank withdrawals in South Africa
Incident Report for Luno
Resolved
The backlog of withdrawals have been cleared, all withdrawals are being processed as normal.
Posted Nov 27, 2019 - 14:27 UTC
Identified
Withdrawals requested in the afternoon of 26 November 2019 may be delayed due to a banking issue. Requested withdrawals will be processed as part of the morning batch on 30 November 2019.

Please see the withdrawal schedule https://www.luno.com/help/articles/11000022934
Posted Nov 26, 2019 - 14:56 UTC