Slow Bank Deposits in Malaysia
Incident Report for Luno
Resolved
Public Bank deposit issues have now been resolved. If you’re a Public Bank account holder, you can now make deposits to Luno as per normal.

Thanks again for your patience.
Posted Aug 03, 2020 - 09:56 UTC
Update
Hong Leong bank deposit issues have now been resolved. If you’re a Hong Leong bank account holder, you can now make deposits to Luno as per normal.

We are still detecting some customers experiencing error messages when making deposits from Public Bank and Alliance bank accounts. An error message is displayed on either the bank’s app or website.

If you are facing similar difficulties, we recommend using a different bank to make deposits to Luno (however, please ensure it’s from a bank account in your own name). If you’re facing issues making deposits from one of those banks, please reach out directly to the customer service department of those banks.

Do note that deposit and withdrawal functions are functioning as per normal for all customers of other banking platforms. We are still investigating and will provide further updates once we have obtained clarification from the affected banks.
Posted Jul 28, 2020 - 09:54 UTC
Update
We’ve detected some customers experiencing error messages when making deposits from Public Bank and Hong Leong bank accounts. An error message is displayed on either the bank’s app or website.

If you are facing similar difficulties, we recommend using a different bank to make deposits to Luno (however, please ensure it’s from a bank account in your own name). If you’re facing issues making deposits from one of those banks, please reach out directly to the customer service department of those banks.

Do note that deposit and withdrawal functions are functioning as per normal for all customers of other banking platforms. We are investigating and will provide further updates once we have obtained clarification from the affected banks.
Posted Jul 27, 2020 - 06:13 UTC
Investigating
We're aware of a delay with Public Band and Hong Leong Bank deposits and our team is currently investigating it. Our team is currently investigating it and working with our service provider to get it resolved. We hope to have this resolved soon.

We hope to have this resolved soon.
Posted Jul 27, 2020 - 06:06 UTC