Scheduled Maintenance in Progress
Incident Report for Luno
Resolved
Maintenance is complete, no impact to Luno services.
Posted Nov 20, 2024 - 11:56 UTC
Update
Maintenance has been delayed to 11:15 UTC.
Posted Nov 20, 2024 - 10:37 UTC
Identified
We're currently implementing a fix to improve our services. During this time, you may experience intermittent disruptions. We're working to complete the update as quickly as possible and apologise for any inconvenience.

We don't expect this to last more than an hour.

Thank you for your patience and understanding!
Posted Nov 20, 2024 - 09:58 UTC