Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Nov 11, 2019 - 11:15 SAST
Investigating
Withdrawals in Nigeria will not be processed on 11 November 2019 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 12 November 2019.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Nov 08, 2019 - 10:03 SAST
This incident affected: Bank deposits and withdrawals (Nigeria).