Delayed Deposits and Withdrawals South Africa
Incident Report for Luno
Resolved
The issue has been resolved. Deposits and withdrawals are working as usual.
Posted Dec 07, 2021 - 13:27 UTC
Monitoring
Deposits and withdrawals are being processed as normal. We will continue monitoring for any further issues.

Thank you for your patience.
Posted Dec 07, 2021 - 09:25 UTC
Identified
We are aware that some of you may be experiencing a delay with your deposits or withdrawals in South Africa.

Our team has implemented a fix but you may still experience some delays. We will update our status page when everything has returned to normal.
Posted Dec 07, 2021 - 08:26 UTC
This incident affected: Bank deposits and withdrawals (South Africa).