Slow Paystack deposits in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved
Posted 4 months ago. Nov 14, 2018 - 18:30 UTC
Identified
Customers in Nigeria may a delay in seeing their deposits reflect in their NGN wallet today.
Our team are aware of the issue and are working closely with Paystack to see this resolved as quickly as possible.
Posted 4 months ago. Nov 14, 2018 - 08:58 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).