Delayed bank deposits and withdrawals in Zambia
Incident Report for Luno
Resolved
Deposits and Withdrawals are being received and processed according to schedule.

Thank you
Posted Jun 29, 2020 - 13:47 UTC
Identified
There are temporary delays with Zambian deposits and withdrawals requested on 26th June to 29th June. There are technical issues with our banking partner but we’re working with them to see this is resolved soon.
Posted Jun 29, 2020 - 13:14 UTC