Account verification maintenance in South Africa
Incident Report for Luno
Resolved
Account verifications are being processed as normal, thanks for your patience.
Posted May 19, 2020 - 07:54 UTC
Monitoring
Account verifications are being processed as normal, we're monitoring closely for any additional errors.
Posted May 18, 2020 - 10:56 UTC
Update
Level 1 account verifications may still be slow for some customers, our team are working on this as a priority.
Posted May 18, 2020 - 06:02 UTC
Update
There may be additional delays as the maintenance still seems to be under way.
We'll update you as soon as that changes.
Posted May 17, 2020 - 16:12 UTC
Identified
One of our providers will be doing routine maintenance on Sunday 17 May starting at 17:00 GMT +2.
This may delay new account verifications for Level 1 and potentially Level 2 accounts. If your account has already been verified there will be no impact. Customers wanting to verify to Level 1 may see a 30 minute delay in having their verification status change.

Maintenance is expected to last no longer than 1 hour.
Posted May 15, 2020 - 13:22 UTC