Public Holiday Reminder - Withdrawal Requests will take longer than usual in Europe
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 08:55 UTC
Identified
Please note that our bank will be acknowledging the public holidays on 29 March and 1 April 2024, therefore they will not be processing EUR payments. This means any EUR withdrawals from Luno that we send to the bank won’t be processed by them until 2 April 2024.

Please note that this only applies to EUR withdrawals. Crypto withdrawals are being processed as normal according to our service level agreements.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 29, 2024 - 08:22 UTC