Afritickets withdrawals temporarily unavailable in Nigeria
Incident Report for Luno
Resolved
This issue has been resolved.

Withdrawals via Afritickets in Nigeria are working as expected.

We apologise for the inconvenience caused and thank you for your patience.
Posted Apr 05, 2024 - 15:24 UTC
Investigating
Afritickets have notified us of an issue on their system causing intermittent withdrawal issues.

We're working with Afritickets to get this resolved as soon as possible.

We apologise for the inconvenience caused.
Posted Apr 05, 2024 - 15:03 UTC