Delayed bank withdrawal in Australia
Incident Report for Luno
Resolved
Withdrawals are being processing accordingly. Thank you.
Posted Dec 29, 2020 - 06:31 UTC
Identified
Withdrawals in Australia will not be processed on the 25th and 28th of December due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on December 29th.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Dec 24, 2020 - 07:04 UTC