Card deposits in Europe
Incident Report for Luno
Resolved
Error rates have returned to normal, Euro deposits via card payments are functional.
Posted 3 months ago. Jul 02, 2019 - 11:33 SAST
Monitoring
We're monitoring for any elevated errors, please retry any failed deposits.
Posted 3 months ago. Jul 02, 2019 - 09:37 SAST
Identified
A similar issue seems to have cropped up causing card deposits to fail for customers in Europe.
Our team are working on this as a priority, sincerely sorry for the inconvenience caused.
Posted 3 months ago. Jul 02, 2019 - 09:08 SAST