Slow Bitcoin sends
Incident Report for Luno
Resolved
Bitcoin send transactions have returned to normal.
Posted 7 days ago. Nov 07, 2018 - 14:58 UTC
Identified
We've identified an issue affecting Bitcoin sends, this means that Bitcoin sent to another wallet address may appear as pending on your wallet.

Our team have identified the issue and are working on a fix, we expect this to be resolved within 2 hours of this incident being posted.
Posted 7 days ago. Nov 07, 2018 - 14:04 UTC
This incident affected: Bitcoin sends and receives.