Delayed account verification
Incident Report for Luno
Resolved
The issue affecting delayed account verification has been resolved.
Posted Jun 06, 2022 - 07:41 UTC
Investigating
We are currently experiencing some delays in account verification.

Our team is working to identify the cause.

Apologies for any delays.
Posted Jun 05, 2022 - 08:58 UTC