Slow Bank Deposits and Withdrawals in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 07:13 UTC
Update
Due to technical difficulties, both bank deposits to our Standard Bank account and withdrawals are currently being affected. We are working on a solution to get this resolved as soon as possible. Deposits to your Luno wallet can still be made with alternative deposit methods.
Posted Mar 16, 2021 - 11:46 UTC
Identified
We're aware of a delay with deposits to Standard Bank in South Africa and our team is currently investigating it. We hope to have this resolved soon. In the meantime, please make use of an alternative deposit method in your Luno wallet.
Posted Mar 16, 2021 - 08:10 UTC