BTC Sends Get Cancelled
Incident Report for Luno
Resolved
This incident has been resolved.

BTC sends have returned to normal.
Posted Jul 16, 2020 - 20:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2020 - 19:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 16, 2020 - 19:20 UTC
Investigating
We're urgently investigating an issue that is affecting BTC sends.

We're working on this as a priority, updates to follow.
Posted Jul 16, 2020 - 19:16 UTC