Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 2 months ago. Aug 13, 2019 - 07:39 SAST
Identified
Withdrawals in Malaysia will not be processed on 12 August 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 13 August 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 2 months ago. Aug 08, 2019 - 08:54 SAST