Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Sep 03, 2019 - 13:47 SAST
Identified
Withdrawals in Malaysia will not be processed on 2 September 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 3 September 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted Aug 30, 2019 - 13:31 SAST