Slow bank deposits in Nigeria
Incident Report for Luno
Resolved
Deposits are being processed as normal.
Posted Oct 25, 2019 - 08:34 SAST
Update
Unfortunately we're still waiting for a resolution from the bank to clear some customers deposits.
Some deposits may be delayed until this can be resolved.
Posted Oct 22, 2019 - 11:00 SAST
Identified
Some customers may experience slower than normal deposit times in Nigeria. This is due to a technical banking issue, our team are awaiting further feedback from the bank.

Deposits from 19 October 2019 are affected.

Updates to follow.
Posted Oct 21, 2019 - 10:47 SAST