Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 11:19 UTC
Identified
Withdrawals in Malaysia will not be processed on 29th April 2021 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 3rd May 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Apr 27, 2021 - 03:53 UTC
This incident affected: Bank deposits and withdrawals (Malaysia).