Slow Bitcoin transactions
Incident Report for Luno
Resolved
Bitcoin transaction times have returned to normal, we'll continue to monitor for any further anomalies.
Posted Oct 06, 2020 - 06:51 UTC
Identified
Slower block times as well as a spike in fees has resulted in a backlog of transactions on the Bitcoin blockchain.

This is out of Luno's control, thankfully this usually clears quite quickly. We'll keep a close eye on transactions.
Posted Oct 05, 2020 - 18:16 UTC