Delayed Account Verification
Incident Report for Luno
Resolved
This issue has been resolved and verification times have returned to normal.

There is no need to resubmit any documents for verification should you have already done so.

We thank you for your patience.
Posted May 10, 2021 - 14:58 UTC
Monitoring
Account verifications are working as normal, we will continue to monitor for any further issues.
Posted May 10, 2021 - 14:35 UTC
Identified
We are currently experiencing delayed customer verifications, we are working on this as a priority.

We thank you for your patience.
Posted May 10, 2021 - 13:49 UTC
This incident affected: Help & account verification (Account verification).