Delayed bank withdrawals in Zambia
Incident Report for Luno
Resolved
Sadly, we’ve had to make the difficult decision to pause all operations in Zambia. Just for a while.

Due to circumstances beyond our control, we haven’t been able to give our Zambian customers the best crypto experience on the planet.

Please see https://www.luno.com/help/en/articles/11000101039 for further details.
Posted Jan 29, 2021 - 10:32 UTC
Identified
There may be temporary delays with Zambia withdrawals requested from 13th January. We’re working with the bank to see this resolved soon.

Thank you
Posted Jan 14, 2021 - 16:02 UTC