Slow bank deposits and withdrawals in Nigeria
Incident Report for Luno
Resolved
Deposits and withdrawals are being processed as normal.
Posted Nov 08, 2019 - 09:50 SAST
Update
We've managed to process some withdrawals, however some deposits and withdrawals may still be delayed.
An update will be posted as soon as we hear differently.
Posted Nov 06, 2019 - 16:42 SAST
Update
We're making good progress with our banking partner and hoping to see all deposit and withdrawal times return to normal during the course of today. Thanks for your patience.
Posted Nov 06, 2019 - 10:32 SAST
Identified
There will be a slight delay with Nigerian bank deposits and withdrawals requested on 5 November 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted Nov 05, 2019 - 10:20 SAST