Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed accordingly. Thank you.
Posted Jan 11, 2021 - 06:29 UTC
Identified
There may be temporary delays with Nigeria withdrawals requested from the 8th of December. We’re working to see this resolved soon.
Posted Jan 09, 2021 - 06:51 UTC