Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawals are being processed according to schedule. Thank you
Posted May 08, 2020 - 06:23 UTC
Identified
Withdrawals in Indonesia will not be processed on May 7th due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on May 8th.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 06, 2020 - 07:10 UTC