Email ticket creation errors
Incident Report for Luno
Resolved
This issue has been resolved and ticket creation has returned to normal.
Posted Jun 11, 2022 - 12:30 UTC
Identified
We have identified an issue causing failed support ticket creation for some customers, we are working to resolve this as a priority.
Posted Jun 11, 2022 - 11:56 UTC
This incident affected: Help & account verification (Support response times) and Supported platforms (Web).