Slow Ethereum transactions
Incident Report for Luno
Resolved
We have resolved the underlying issue and both sends and receives have returned back to normal.

We'll continue to monitor closely.

Thanks for your patience.
Posted Mar 19, 2021 - 11:15 UTC
Investigating
We're investigating an issue causing some ETH send and receive transactions to be delayed, our team is working on this as a priority.
Posted Mar 19, 2021 - 08:43 UTC
This incident affected: Crypto sends and receives (ETH).