Unable to submit tickets
Incident Report for Luno
Resolved
The issue has been resolved. Support tickets can be created as normal.
Posted Feb 10, 2021 - 13:17 UTC
Monitoring
Our team have resolved the issue and are monitoring the results, support tickets can be created as normal.

Thanks for your patience.
Posted Feb 10, 2021 - 12:41 UTC
Identified
We have identified an issue where customers are unable to submit tickets to our team.

We're investigating urgently.
Posted Feb 10, 2021 - 12:30 UTC