Delayed bank withdrawals in Zambia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Oct 31, 2020 - 06:18 UTC
Identified
There may be temporary delays with Zambia withdrawals requested on 30 October 2020. We’re working with the bank to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Oct 30, 2020 - 13:41 UTC