Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 03:00 UTC
Identified
Certain withdrawals in Indonesia will not be processed on 1st June 2021 due to the public holiday. Unfortunately, banks do not process such withdrawals over weekends or public holidays.

These withdrawals will be processed on 2nd June 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 31, 2021 - 03:48 UTC