Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jul 06, 2020 - 16:40 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 06, 2020 - 16:40 UTC
Identified
There may be temporary delays with Nigeria withdrawals requested from 6th of July. We’re working with the bank to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jul 06, 2020 - 14:01 UTC