Delayed bank withdrawals in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 05:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2021 - 05:18 UTC
Identified
We are aware that some of you may be facing an issue with withdrawals in Indonesia. Please bear with us as we are working with our service provider to see this resolved soon.

We will provide an update once the issue has been fixed.

Thank you.
Posted Nov 05, 2021 - 10:02 UTC