Delayed bank withdrawals in Australia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Jul 06, 2021 - 03:43 UTC
Identified
There are temporary delays with Australia withdrawals requested since 4th July 2021. We’re working with our service provider to see this resolved and will provide an update soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jul 05, 2021 - 03:26 UTC