Microsoft Email Delivery
Incident Report for Luno
Resolved
We’re confident that this has now been resolved.

For those that were affected by this incident, it’s possible that our reply to you may have been lost. If you’re waiting to hear from us, we’d suggest that you mail us again.

We thank you for your patience.
Posted Jun 16, 2021 - 11:16 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2021 - 08:29 UTC
Identified
We've identified an issue with Luno email delivery to anyone who uses email hosted by Microsoft.

As a result, you may not receive Luno emails such as buy, sell, or send confirmations, security alerts, customer support responses, or other notifications. If you're not receiving any emails from us, it's possible that it could be in your spam folder. It may also be quarantined by your email system. If that's the case, we'd suggest that you ask your systems administrator to release the emails.

We're working on getting Microsoft to fix this error as soon as possible.

We appreciate you bearing with us.
Posted Jun 15, 2021 - 08:20 UTC
This incident affected: Help & account verification (Support response times).