Delayed bank withdrawal in Uganda
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 10:13 UTC
Identified
Withdrawals in Uganda will not be processed on 8 March 2021 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 9 March 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 08, 2021 - 07:08 UTC